Subversion 1.6 on Debian Lenny

Currently the Version of Subversion in Debian Lenny is 1.5.1, there are a few bugs in this that could be show stoppers if you are using a write through proxy setup for your SVN Repo’s as i have. There are two bugs that keep cropping up, one that is solved in 1.5.5, the other in 1.6, however if you want to use debian packages the easiest way i have found to install them is as follows

Update 1: Few people are having problems, this guide assumes your running lenny with the default svn packages already installed, to do this try running the command below to install the latest version from apt (1.5.x as i write this) including the required Apache modules

Update 2: New post on how to extend this guide to go from svn 1.6.1 to svn 1.6.3 – Debian: Upgrade Svn 1.6.1 to 1.6.3

Update 3:This post was originally just some notes for me on highly critical production servers that all had to be running exactly the same versions and i had to have a very controled upgrade, However google sends a few hundred people here a month! So i thought id include the better general way that has been in the comments for awhile

Update 4: Guide now available for SVN 1.7

The best way are the commands below.

Original Post

32Bit

64 Bit

12 Comments

There are new versions of libapr1 (1.3.3_4) and libaprutil1 (1.3.4+dfsg-2) available.

Also, there seems to be a dependency issue with Apache, please see output below

dpkg: regarding libaprutil1_1.3.4+dfsg-2_amd64.deb containing libaprutil1:
libaprutil1 breaks apache2.2-common (<< 2.2.11-3)
apache2.2-common (version 2.2.9-10+lenny2) is present and installed.
dpkg: error processing libaprutil1_1.3.4+dfsg-2_amd64.deb (–install):
installing libaprutil1 would break apache2.2-common, and
deconfiguration is not permitted (–auto-deconfigure might help)
Errors were encountered while processing:
libaprutil1_1.3.4+dfsg-2_amd64.deb

Marc says:

We also cannot install it:

The following packages have unmet dependencies:
apache2.2-common: Depends: apache2-utils but it is not going to be installed
libaprutil1: Breaks: apache2.2-common (= 0.28.2) but it is not going to be installed

* Scott says:

By default the package assumes your going to be using an Apache front-end

try “apt-get install apache2 libapache2-svn”

[…] Previous post Subversion 1.6 on Debian Lenny has been quite popular! So i thought i should post this next snippet for people, Its the process i […]

John Swetres says:

The problem is, if apache is already installed on system from the stable repo of course, there is no way you can install SVN 1.6 because of the above mentioned apache dependency. Both apache and svn depend on libapr1 package.

I hope to find a svn client-only package, like the ones for windows (slik svn etc.)

Jim says:

I was able to fix this only by adding squeeze to sources, and updating apache to 2.2.11 (there was a fork error, but that’s something else). Everything else horribly breaks my VPS.

Here is an alternate way of accomplishing this.

dpkg is an aging utility, and isn’t as great as aptitude. I would recommend getting the lenny-backport version of subversion (currently 1.6.4) from the backports repo.

Steps:

* Add lenny-backports to sources.list: http://backports.org/dokuwiki/doku.php?id=instructions
* sudo aptitude update
* sudo aptitude -t lenny-backports install subversion

[…] alkoi googlettamalla ongelmalle ratkaisua. Löytyi tämä. Siellä henkilö Jameson Williams toi esiin paremman […]

n0nick says:

Thanks Jameson Williams – your solution worked and is a much cleaner way I think.

The download links in the original post are all broken (404), btw.

Wascou says:

Thanks Jameson Williams !
I was searching this one for a long time ! That’s cleaner than squeeze…

Mark Wickens says:

Yep, worked for me great, thanks for the help.
Mark.

David says:

Out of date. Running debian, lenny, this worked for me:
echo “deb http://backports.debian.org/debian-backports lenny-backports main” /etc/apt/sources.list
apt-get update
apt-get -t lenny-backports install subversion

Leave a Reply

Your email address will not be published.